summaryrefslogtreecommitdiff
path: root/tests/auto/qplaceratings/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Solovev <ivan.solovev@qt.io>2021-10-27 17:55:30 +0200
committerIvan Solovev <ivan.solovev@qt.io>2021-11-09 10:28:16 +0100
commit052a247133fe98a5941a570134b48a7b97853092 (patch)
tree063be8259a3c6056d91438765602ca8432baaa4e /tests/auto/qplaceratings/CMakeLists.txt
parente7bc51e4c5c07389c1d028e7a42c238688ca43ee (diff)
downloadqtlocation-052a247133fe98a5941a570134b48a7b97853092.tar.gz
Build minimal subset of QtLocation with unit-tests
Build src/location/maps and src/location/places with a minimum subset of required src/location/declarativemaps files. Also build all plugins except mapbox-gl. Enable all non-QML unit-tests. Task-number: QTBUG-97769 Change-Id: I7c70584376c688efd2e1d046186732a7399e12d9 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alex Blasche <alexander.blasche@qt.io>
Diffstat (limited to 'tests/auto/qplaceratings/CMakeLists.txt')
-rw-r--r--tests/auto/qplaceratings/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/auto/qplaceratings/CMakeLists.txt b/tests/auto/qplaceratings/CMakeLists.txt
new file mode 100644
index 00000000..29aee1f7
--- /dev/null
+++ b/tests/auto/qplaceratings/CMakeLists.txt
@@ -0,0 +1,7 @@
+qt_internal_add_test(tst_qplaceratings
+ SOURCES
+ tst_qplaceratings.cpp
+ LIBRARIES
+ Qt::Core
+ Qt::Location
+)