summaryrefslogtreecommitdiff
path: root/src/plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Solovev <ivan.solovev@qt.io>2021-01-06 17:37:02 +0100
committerIvan Solovev <ivan.solovev@qt.io>2021-01-20 14:10:41 +0100
commit65ce5e64aa549c536d36d6ae9c18ffd8c8eee0d6 (patch)
tree7d0e6db8287908336e9b0075bcc7bef0c1ed1660 /src/plugins/CMakeLists.txt
parent89f1e45e487ca6ae3998699153b10c343aef25d9 (diff)
downloadqtlocation-65ce5e64aa549c536d36d6ae9c18ffd8c8eee0d6.tar.gz
QtPositioning: port to cmake
Switching QtPositioning, its tests and examples to cmake. QtLocation is not covered by this patch. Task-number: QTBUG-89854 Change-Id: Ic971f7fd4c576eac9b662641aae77d68c062712d Reviewed-by: Alex Blasche <alexander.blasche@qt.io>
Diffstat (limited to 'src/plugins/CMakeLists.txt')
-rw-r--r--src/plugins/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/plugins/CMakeLists.txt b/src/plugins/CMakeLists.txt
new file mode 100644
index 00000000..bf9732ab
--- /dev/null
+++ b/src/plugins/CMakeLists.txt
@@ -0,0 +1,9 @@
+# Generated from plugins.pro.
+
+if(TARGET Qt::Positioning)
+ add_subdirectory(position)
+endif()
+# TODO: enable location plugins later!
+# if(TARGET Qt::Location)
+# add_subdirectory(geoservices)
+# endif()