summaryrefslogtreecommitdiff
path: root/examples/location/geojson_viewer/CMakeLists.txt
diff options
context:
space:
mode:
authorShawn Rutledge <shawn.rutledge@qt.io>2022-11-14 21:19:30 +0100
committerShawn Rutledge <shawn.rutledge@qt.io>2022-11-15 10:56:23 +0100
commit76c0afd59040b158379c2b9fe116a8fead82f308 (patch)
treef124521fb4012cc73dc01b4f4ba462ca355408fc /examples/location/geojson_viewer/CMakeLists.txt
parent70c6c9df8ea961d28e7e513450856db7e497abd7 (diff)
downloadqtlocation-76c0afd59040b158379c2b9fe116a8fead82f308.tar.gz
Get the geojson example working again
fdbbfa4a6723b816478ee011ab4098e5332dc2f5 removed MapObjectView, but this example continued to depend on it. This reverts parts of commit be7cbed7411d024d178377bd327d5916c80e02a0. Also: - use QtCore.StandardPaths rather than Qt.labs.platform - remove the widgets dependency - use FileDialog.nameFilters to read and write geojson files Let's assume that FileDialog.selectedFile will actually output a QUrl to save the file to, as opposed to a plain path, since the dumpGeoJSON() function is calling toLocalFile() on it. At least that works with native dialogs. Task-number: QTBUG-108455 Change-Id: I1f14c6425115aa95ac2080438ff0c3a24b1b7196 Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io>
Diffstat (limited to 'examples/location/geojson_viewer/CMakeLists.txt')
-rw-r--r--examples/location/geojson_viewer/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/examples/location/geojson_viewer/CMakeLists.txt b/examples/location/geojson_viewer/CMakeLists.txt
index 7de77f58..8a584b8c 100644
--- a/examples/location/geojson_viewer/CMakeLists.txt
+++ b/examples/location/geojson_viewer/CMakeLists.txt
@@ -22,7 +22,6 @@ find_package(Qt6 COMPONENTS Network)
find_package(Qt6 COMPONENTS Quick)
find_package(Qt6 COMPONENTS Positioning)
find_package(Qt6 COMPONENTS Location)
-find_package(Qt6 COMPONENTS Widgets)
qt_add_executable(qml_location_geojsonviewer WIN32 MACOSX_BUNDLE
main.cpp
@@ -35,7 +34,6 @@ target_link_libraries(qml_location_geojsonviewer PUBLIC
Qt::Positioning
Qt::Qml
Qt::Quick
- Qt::Widgets
)