summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Solovev <ivan.solovev@qt.io>2021-10-29 18:23:27 +0300
committerLauri Laanmets <lauri.laanmets@eesti.ee>2022-02-28 17:11:40 +0200
commite40cd29cff975a5d564de87e1a6f0c7341bcdbd5 (patch)
tree381b5abadde1e241644ecd559b580e74d6d9d1b5 /CMakeLists.txt
parent6cb20a08b65c73b46e0201213869d213e0397791 (diff)
downloadqtlocation-e40cd29cff975a5d564de87e1a6f0c7341bcdbd5.tar.gz
Finalize QtLocation CMake build
Add missing files from declarativemaps and declarativeplaces. Reintroduce Qt.labs.location feature (currently always enabled, as I'm not sure that OpenGL is strictly required for now). Build Qt.location.labs as part of QtLocation lib when this feature is enabled. Also update build files for plugins to take this feature into account. Build QML plugins as two separate QML modules. This still requires some improvements because the code does not use QML_* macros, but an old-style qmlRegister* approach. Task-number: QTBUG-96795 Change-Id: Ib835848ca3ad551cc6d858d2bae10b9aa4df5160 Reviewed-by: Andreas Buhr <andreas.buhr@qt.io> Reviewed-by: Alexey Edelev <alexey.edelev@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3093a349..88602360 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,7 +23,7 @@ endif()
# Need to search for positioning only after we make sure that it's not WASM.
# Otherwise we'll get an "QtPositioning not found" error in WASM build.
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS Positioning Network) # special case
-find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Quick Qml Test QuickTest PositioningQuick) # special case
+find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Quick Qml Test QuickTest PositioningQuick ShaderTools) # special case
macro(assertTargets)
foreach(qtTarget IN ITEMS ${ARGN})
@@ -34,6 +34,6 @@ macro(assertTargets)
endforeach()
endmacro()
-assertTargets(Quick PositioningQuick)
+assertTargets(Quick PositioningQuick ShaderTools)
qt_build_repo()