summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLauri Laanmets <lauri.laanmets@eesti.ee>2022-03-08 09:30:43 +0200
committerVolker Hilsheimer <volker.hilsheimer@qt.io>2022-07-26 14:28:38 +0200
commitc4712ad8c5e7701429e9184db6ec91a4008566e2 (patch)
tree82ce229de262b75cd46ae8932153732f6a16bd96 /CMakeLists.txt
parent24804c8b9a5651a8088bf9479990df5830473fbb (diff)
downloadqtlocation-c4712ad8c5e7701429e9184db6ec91a4008566e2.tar.gz
Manual fixes in CMake files for examples
Improvements in CMake files after they have been generated from .pro files by script. All examples except 'places' are included because 'places' example doesn't start (not ported yet). Task-number: QTBUG-96795 Pick-to: 6.2 Change-Id: I1fab82821f499f51337440274d0b66082f614fca Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3f041881..5f8e7360 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,6 +29,11 @@ endif()
# Otherwise we'll get an "QtPositioning not found" error in WASM build.
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS Positioning Network) # special case
find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Quick Qml Test QuickTest PositioningQuick ShaderTools) # special case
+find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS
+ # Needed when building examples in-tree
+ Widgets
+ Sql
+)
macro(assertTargets)
foreach(qtTarget IN ITEMS ${ARGN})