summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVolker Hilsheimer <volker.hilsheimer@qt.io>2022-06-11 14:09:24 +0200
committerVolker Hilsheimer <volker.hilsheimer@qt.io>2022-06-16 16:09:10 +0200
commit9bd3b391105d7ac4c1f620f1129c6a73f21c289d (patch)
tree7ca032887e352ccdf31a76203d49a4fd32b3c5bb /CMakeLists.txt
parent5b3cc7c418b6b85602450d14289880fdc1e69492 (diff)
downloadqtlocation-9bd3b391105d7ac4c1f620f1129c6a73f21c289d.tar.gz
Skip Qt Location build for now on INTEGRITY
Build errors in CI blocking progress, needs to be built locally by someone with access to the toolchain. Change-Id: Ic7b369dc99a5bda0b26c2721400fdd58e24bca68 Reviewed-by: Kimmo Ollila <kimmo.ollila@qt.io> Reviewed-by: Tatiana Borisova <tatiana.borisova@qt.io> Reviewed-by: Alex Blasche <alexander.blasche@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 88602360..3f041881 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,6 +20,11 @@ if(WASM)
return()
endif()
+if(INTEGRITY)
+ message(NOTICE "Skipping the build as the condition \"NOT INTEGRITY\" is not met.")
+ return()
+endif()
+
# Need to search for positioning only after we make sure that it's not WASM.
# Otherwise we'll get an "QtPositioning not found" error in WASM build.
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS Positioning Network) # special case