summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Solovev <ivan.solovev@qt.io>2021-01-06 17:37:02 +0100
committerIvan Solovev <ivan.solovev@qt.io>2021-01-20 14:10:41 +0100
commit65ce5e64aa549c536d36d6ae9c18ffd8c8eee0d6 (patch)
tree7d0e6db8287908336e9b0075bcc7bef0c1ed1660 /CMakeLists.txt
parent89f1e45e487ca6ae3998699153b10c343aef25d9 (diff)
downloadqtlocation-65ce5e64aa549c536d36d6ae9c18ffd8c8eee0d6.tar.gz
QtPositioning: port to cmake
Switching QtPositioning, its tests and examples to cmake. QtLocation is not covered by this patch. Task-number: QTBUG-89854 Change-Id: Ic971f7fd4c576eac9b662641aae77d68c062712d Reviewed-by: Alex Blasche <alexander.blasche@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 00000000..5d0cc0c1
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,21 @@
+# Generated from qtlocation.pro.
+
+cmake_minimum_required(VERSION 3.15.0)
+
+include(.cmake.conf)
+project(QtLocation
+ VERSION "${QT_REPO_MODULE_VERSION}"
+ DESCRIPTION "Qt Location Libraries"
+ HOMEPAGE_URL "https://qt.io/"
+ LANGUAGES CXX C
+)
+
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core) # special case
+find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Quick Qml Gui Widgets Network Test DBus SerialPort) # special case
+# add simulator later. Probably smth else from QtLocation dependencies
+
+if(WASM)
+ message(NOTICE "Skipping the build as the condition \"NOT WASM\" is not met.")
+ return()
+endif()
+qt_build_repo()