summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLaszlo Agocs <laszlo.agocs@qt.io>2022-11-30 12:12:03 +0100
committerMatthias Rauter <matthias.rauter@qt.io>2023-02-08 09:28:10 +0100
commit34fccf47ecf8ab2db53b23013f4f402c175ce9de (patch)
tree48d3ad9eb9d7568e29f0877e8ed9d49da98b6ce1 /CMakeLists.txt
parentcd4db512ae08836f5fa1d746000052215cf70a9c (diff)
downloadqtlocation-34fccf47ecf8ab2db53b23013f4f402c175ce9de.tar.gz
Implement all four map items with Shape
With a master switch in qdeclarativegeomapitembase_p.h, this is enabled by default. For now the old method is still available by just commenting out the define. The old path can be removed in follow-up patches; for now keeping both so one can compare and debug if further issues arise. Pick-to: 6.5 Change-Id: I01c44ee8a07d7d5f7eb018be33ac5d161ba90e2a Reviewed-by: Matthias Rauter <matthias.rauter@qt.io> Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2c186a19..7bc5110f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,7 +28,7 @@ endif()
# Need to search for positioning only after we make sure that it's not WASM.
# Otherwise we'll get an "QtPositioning not found" error in WASM build.
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS
- Qml Quick Network Test QuickTest Positioning PositioningQuick
+ Qml Quick Network Test QuickTest Positioning PositioningQuick QuickShapesPrivate
)
find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS
ShaderTools