summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Solovev <ivan.solovev@qt.io>2021-01-27 18:18:46 +0100
committerIvan Solovev <ivan.solovev@qt.io>2021-02-09 11:10:26 +0100
commit32f7ffbe7307c02fce1493d43cdaf87bf0f1f1d7 (patch)
treec2a3f110f88f66afac59b278ddbf48da5ec0f556 /CMakeLists.txt
parent752f7c79d3bb8c350139d48c9622d426f7ad86d2 (diff)
downloadqtlocation-32f7ffbe7307c02fce1493d43cdaf87bf0f1f1d7.tar.gz
QtPositioning: refactor unit tests
Some of the QtPositioning QML unit tests can be separated from the QtLocation tests, and run with QtPositioning and QtPositioningQuick only. This patch moves such unit tests into separate subdirectory. It also updated the tests to reflect the changes in Qt6: Since Qt6 the variant type behaves as var, so the tests that rely on the obsolete behavior need to be updated. The QGeoShape::center() method is no longer marked Q_INVOKABLE, because with updated Qt6 behavior it overrides the center properties of the child classes (like QGeoCircle or QGeoRectangle). It's marked as a read-only property instread, so that it could still be accessed from QML code. [ChangeLog][QtPositioning][QGeoShape] center is now a read-only property. The center() function is no longer a Q_INVOKABLE. Task-number: QTBUG-90491 Task-number: QTBUG-90836 Change-Id: I3c7993aa8abe1199e825d46ab19ccfb53902018f Reviewed-by: Alex Blasche <alexander.blasche@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1cd38cc6..8401b7d9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,7 +11,7 @@ project(QtLocation
)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core) # special case
-find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Quick Qml Gui Widgets Network Test DBus SerialPort) # special case
+find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Quick Qml Gui Widgets Network Test DBus SerialPort QuickTest) # special case
# add simulator later. Probably smth else from QtLocation dependencies
if(WASM)