summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Solovev <ivan.solovev@qt.io>2021-10-21 17:27:08 +0200
committerIvan Solovev <ivan.solovev@qt.io>2021-10-27 11:24:52 +0200
commit23f32792ad53e23bbafbff6d7667f0bb0f69fc53 (patch)
tree44b193a019432b664ed3e3967bd276849132d24b /CMakeLists.txt
parentd2871cc9d864306fa7a985d4d5d4353c9369f44a (diff)
downloadqtlocation-23f32792ad53e23bbafbff6d7667f0bb0f69fc53.tar.gz
Remove QtPositioning module from qtlocation.git
Turns out that our CI does not support repos without any tests. This is treated like an error and leads to integration failure. This patch fixes it by disabling tests in coin/module_config.yaml. This config should be fixed when QtLocation tests are enabled Pick-to: 6.2 Task-number: QTBUG-97084 Change-Id: Ib06e865fe2836806bbbee34345f06b471dd48660 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alex Blasche <alexander.blasche@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 198e7be2..60a37ba6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,11 +14,15 @@ project(QtLocation
set(QT_USE_FIXED_QT_ADD_RESOURCE_BASE TRUE)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core) # special case
-find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Quick Qml Gui Widgets Network Test DBus SerialPort QuickTest) # special case
-# add simulator later. Probably smth else from QtLocation dependencies
if(WASM)
message(NOTICE "Skipping the build as the condition \"NOT WASM\" is not met.")
return()
endif()
+
+# Need to search for positioning only after we make sure that it's not WASM.
+# Otherwise we'll get an "QtPositioning not found" error in WASM build.
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS Positioning) # special case
+find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Quick Qml Gui Widgets Network Test QuickTest PositioningQuick) # special case
+
qt_build_repo()