summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Solovev <ivan.solovev@qt.io>2021-10-27 17:55:30 +0200
committerIvan Solovev <ivan.solovev@qt.io>2021-11-09 10:28:16 +0100
commit052a247133fe98a5941a570134b48a7b97853092 (patch)
tree063be8259a3c6056d91438765602ca8432baaa4e /CMakeLists.txt
parente7bc51e4c5c07389c1d028e7a42c238688ca43ee (diff)
downloadqtlocation-052a247133fe98a5941a570134b48a7b97853092.tar.gz
Build minimal subset of QtLocation with unit-tests
Build src/location/maps and src/location/places with a minimum subset of required src/location/declarativemaps files. Also build all plugins except mapbox-gl. Enable all non-QML unit-tests. Task-number: QTBUG-97769 Change-Id: I7c70584376c688efd2e1d046186732a7399e12d9 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alex Blasche <alexander.blasche@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 60a37ba6..ead9a48e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,6 +23,17 @@ endif()
# Need to search for positioning only after we make sure that it's not WASM.
# Otherwise we'll get an "QtPositioning not found" error in WASM build.
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS Positioning) # special case
-find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Quick Qml Gui Widgets Network Test QuickTest PositioningQuick) # special case
+find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Quick Qml Network Test QuickTest PositioningQuick) # special case
+
+macro(assertTargets)
+ foreach(qtTarget IN ITEMS ${ARGN})
+ if(NOT TARGET Qt::${qtTarget})
+ message(NOTICE "Skipping the build as the condition \"TARGET Qt::${qtTarget}\" is not met.")
+ return()
+ endif()
+ endforeach()
+endmacro()
+
+assertTargets(Quick PositioningQuick)
qt_build_repo()