summaryrefslogtreecommitdiff
path: root/next/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'next/test/CMakeLists.txt')
-rw-r--r--next/test/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/next/test/CMakeLists.txt b/next/test/CMakeLists.txt
index ce980f78d1..a9814aa033 100644
--- a/next/test/CMakeLists.txt
+++ b/next/test/CMakeLists.txt
@@ -117,7 +117,7 @@ if(MBGL_WITH_OPENGL)
)
endif()
-if(WIN32 OR CMAKE_SYSTEM_NAME STREQUAL Android)
+if(WIN32 OR CMAKE_SYSTEM_NAME STREQUAL Android AND ANDROID_NATIVE_API_LEVEL VERSION_LESS 24)
message("Target platform does not support HTTP tests or dependencies not found.")
set(MBGL_TEST_HAS_TEST_SERVER 0)