summaryrefslogtreecommitdiff
path: root/next/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'next/CMakeLists.txt')
-rw-r--r--next/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/next/CMakeLists.txt b/next/CMakeLists.txt
index df56f04b22..5c95003054 100644
--- a/next/CMakeLists.txt
+++ b/next/CMakeLists.txt
@@ -877,8 +877,9 @@ target_include_directories(
PUBLIC ${MBGL_ROOT}/include
)
-add_subdirectory(${PROJECT_SOURCE_DIR}/vendor/mapbox-base/mapbox)
-add_subdirectory(${PROJECT_SOURCE_DIR}/vendor/mapbox-base/extras)
+if(NOT TARGET mapbox-base)
+ add_subdirectory(${PROJECT_SOURCE_DIR}/vendor/mapbox-base)
+endif()
include(${PROJECT_SOURCE_DIR}/vendor/boost.cmake)
include(${PROJECT_SOURCE_DIR}/vendor/earcut.hpp.cmake)