summaryrefslogtreecommitdiff
path: root/benchmark/android/app/build.gradle
diff options
context:
space:
mode:
Diffstat (limited to 'benchmark/android/app/build.gradle')
-rw-r--r--benchmark/android/app/build.gradle52
1 files changed, 52 insertions, 0 deletions
diff --git a/benchmark/android/app/build.gradle b/benchmark/android/app/build.gradle
new file mode 100644
index 0000000000..d355286585
--- /dev/null
+++ b/benchmark/android/app/build.gradle
@@ -0,0 +1,52 @@
+apply plugin: 'com.android.application'
+
+android {
+ compileSdkVersion 28
+
+ defaultConfig {
+ applicationId = 'com.mapbox.mapboxsdk.maps.benchmark_runner'
+ minSdkVersion 14
+ targetSdkVersion 28
+ def abi = 'all'
+ if (project.hasProperty('mapbox.abis')) {
+ abi = project.getProperty('mapbox.abis')
+ }
+ ndk {
+ if (abi != 'all') {
+ abiFilters abi.split(' ')
+ } else {
+ abiFilters 'armeabi-v7a', 'x86', 'arm64-v8a', 'x86_64'
+ }
+ }
+ externalNativeBuild {
+ cmake {
+ arguments '-DANDROID_CCACHE=ccache'
+ arguments '-DANDROID_STL=c++_static'
+ targets 'mbgl-benchmark-runner'
+ }
+ }
+ android {
+ testBuildType 'release'
+ }
+ testInstrumentationRunner 'androidx.test.runner.AndroidJUnitRunner'
+ }
+ externalNativeBuild {
+ cmake {
+ version '3.10.2'
+ path '../../../next/CMakeLists.txt'
+ }
+ }
+ buildTypes {
+ release {
+ signingConfig signingConfigs.debug
+ }
+ }
+}
+
+dependencies {
+ implementation 'androidx.appcompat:appcompat:1.1.0'
+ implementation 'androidx.constraintlayout:constraintlayout:1.1.3'
+ androidTestImplementation 'androidx.test.ext:junit:1.1.1'
+ androidTestImplementation 'androidx.test.espresso:espresso-core:3.2.0'
+ androidTestImplementation 'androidx.test:rules:1.2.0'
+}