summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Shalamov <alexander.shalamov@mapbox.com>2020-03-02 15:36:13 +0200
committerAlexander Shalamov <alexander.shalamov@mapbox.com>2020-03-05 17:43:37 +0200
commit9a0bc1b58b775209417582867c713b2015353a78 (patch)
tree1b4c5cc9074f2c260cdca4818bce2bfe9fde6fa2 /test/CMakeLists.txt
parentdeca8186147299b72061c1f2e67c13da8f07e0a6 (diff)
downloadqtlocation-mapboxgl-9a0bc1b58b775209417582867c713b2015353a78.tar.gz
[core] Add snapshotter unit tests
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 75d5ee3ef8..0248582c61 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -105,6 +105,17 @@ add_library(
${PROJECT_SOURCE_DIR}/test/util/url.test.cpp
)
+# MapSnapshotter uses headless backend that is rendering image on a background thread. QT / macOS adaptation for headless backend creates
+# new window and updates it's parameters, which is not allowed since macOS mohave 10.14. Following block disables snapshotter unit tests for
+# QT on macOS. https://github.com/mapbox/mapbox-gl-native/issues/16267
+if(NOT (MBGL_WITH_QT AND CMAKE_SYSTEM_NAME STREQUAL Darwin))
+ target_sources(
+ mbgl-test
+ PRIVATE
+ ${PROJECT_SOURCE_DIR}/platform/default/src/mbgl/map/map_snapshotter.cpp ${PROJECT_SOURCE_DIR}/test/map/map_snapshotter.test.cpp
+ )
+endif()
+
if(MBGL_WITH_OPENGL)
target_sources(
mbgl-test