summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKonstantin Käfer <mail@kkaefer.com>2018-11-20 16:45:53 +0100
committerKonstantin Käfer <mail@kkaefer.com>2018-11-21 10:12:59 +0100
commitf30429832e78600b8100a812fb50bcf1b949d567 (patch)
tree567c4a57b6167e8b4cb4ec81221843ff4de22385 /CMakeLists.txt
parent53bbf9d6991c1eddfa141ddcfb4b7252874e46ec (diff)
downloadqtlocation-mapboxgl-f30429832e78600b8100a812fb50bcf1b949d567.tar.gz
[build] use GLFW as a submodule and update to most recent version
this fixes https://github.com/glfw/glfw/issues/1334 for macOS Mojave
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a48e2c2b01..5db8b45894 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,6 +19,8 @@ set(CMAKE_C_VISIBILITY_PRESET hidden)
set(CMAKE_POSITION_INDEPENDENT_CODE ON)
set(CMAKE_VISIBILITY_INLINES_HIDDEN 1)
+set(CMAKE_OSX_DEPLOYMENT_TARGET 10.11)
+
option(WITH_CXX11ABI "Use the C++11 ABI" OFF)
option(WITH_COVERAGE "Enable coverage reports" OFF)
option(WITH_OSMESA "Use OSMesa headless backend" OFF)
@@ -31,8 +33,8 @@ if (WITH_ERROR)
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror")
endif()
-include(cmake/vendor.cmake)
include(cmake/mbgl.cmake)
+include(cmake/vendor.cmake)
include(cmake/mason.cmake)
include(cmake/xcode.cmake)