summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThiago Marcos P. Santos <tmpsantos@gmail.com>2020-03-08 17:43:45 +0200
committerGitHub <noreply@github.com>2020-03-08 17:43:45 +0200
commite6024a2e020ce28f87a785522b99212f91ed3ce4 (patch)
treec4486299dc6650fb9b061477bc736043f5d5ed7e /CMakeLists.txt
parent33b4fea10560bcb24148b26edb94983d628fd48b (diff)
downloadqtlocation-mapboxgl-e6024a2e020ce28f87a785522b99212f91ed3ce4.tar.gz
[build] Do not do license check on core only builds (#16276)
Users will add more dependencies and the script will break the build.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4b7c98eac3..588975e589 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -980,8 +980,6 @@ set_target_properties(
INTERFACE_MAPBOX_LICENSE ${PROJECT_SOURCE_DIR}/LICENSE.md
)
-include(${PROJECT_SOURCE_DIR}/scripts/license.cmake)
-
set_property(TARGET mbgl-core PROPERTY FOLDER Core)
add_library(
@@ -994,7 +992,11 @@ endif()
if(MBGL_WITH_CORE_ONLY)
return()
-elseif(MBGL_WITH_QT)
+endif()
+
+include(${PROJECT_SOURCE_DIR}/scripts/license.cmake)
+
+if(MBGL_WITH_QT)
include(${PROJECT_SOURCE_DIR}/platform/qt/qt.cmake)
elseif(CMAKE_SYSTEM_NAME STREQUAL Android)
include(${PROJECT_SOURCE_DIR}/platform/android/android.cmake)