summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJuha Alanen <juha.alanen@mapbox.com>2020-02-24 17:04:37 +0200
committerJuha Alanen <juha.alanen@mapbox.com>2020-02-27 10:09:35 +0200
commitb756ff8e14037d4f25db1a14c7533ca513a0f2e0 (patch)
treeefa70a292398f2cb0d814d841ae023b78c86f0a5 /CMakeLists.txt
parent18e9ed1c0b7007a0d4e2ce14ed687270900e24ba (diff)
downloadqtlocation-mapboxgl-b756ff8e14037d4f25db1a14c7533ca513a0f2e0.tar.gz
[build][ios] Move iOS specific ccache scripts to platform directory
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 0 insertions, 20 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0a09f09661..05ba29a96f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,26 +1,6 @@
cmake_minimum_required(VERSION 3.10 FATAL_ERROR)
project("Mapbox GL Native" LANGUAGES CXX C)
-find_program(CCACHE_PROGRAM ccache)
-if(CCACHE_PROGRAM AND CMAKE_SYSTEM_NAME STREQUAL "iOS")
- # Set up wrapper scripts
- set(C_LAUNCHER "${CCACHE_PROGRAM}")
- set(CXX_LAUNCHER "${CCACHE_PROGRAM}")
- configure_file(${PROJECT_SOURCE_DIR}/scripts/ci/ccache-c.in ccache-c)
- configure_file(${PROJECT_SOURCE_DIR}/scripts/ci/ccache-cxx.in ccache-cxx)
- execute_process(
- COMMAND
- chmod
- a+rx
- "${CMAKE_BINARY_DIR}/ccache-c"
- "${CMAKE_BINARY_DIR}/ccache-cxx"
- )
-
- # Set Xcode project attributes to route compilation and linking through our scripts
- set(CMAKE_XCODE_ATTRIBUTE_CC "${CMAKE_BINARY_DIR}/ccache-c")
- set(CMAKE_XCODE_ATTRIBUTE_CXX "${CMAKE_BINARY_DIR}/ccache-cxx")
-endif()
-
set_property(GLOBAL PROPERTY USE_FOLDERS ON)
set_property(GLOBAL PROPERTY PREDEFINED_TARGETS_FOLDER Core)