summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas Moenicke <thomas.moenicke@mapbox.com>2020-02-03 19:10:57 +0200
committerGitHub <noreply@github.com>2020-02-03 19:10:57 +0200
commitb64ed754442b894f3914a4191798fbd2f2bc8cd9 (patch)
tree59bb14829d7cdd5f2466dad4cffb74c4d1b80068 /CMakeLists.txt
parent2e10d3548a8b3aff1f28b9514594c3c14509f084 (diff)
downloadqtlocation-mapboxgl-b64ed754442b894f3914a4191798fbd2f2bc8cd9.tar.gz
[build] Adding a build flag to build without GL if needed (#16120)
* [build] Adding a build flag to build without GL if needed * [build] Moving custom layer to mbgl/gl
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2547cfd5ca..9244a5e501 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -163,6 +163,8 @@ endif()
include(platform/${MBGL_PLATFORM}/config.cmake)
+add_definitions(-DMBGL_RENDER_BACKEND_OPENGL=1)
+
if(WITH_EGL)
add_definitions(-DMBGL_WITH_EGL=1)
endif()