summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKonstantin Käfer <mail@kkaefer.com>2019-08-16 12:03:53 +0200
committerAlexander Shalamov <alexander.shalamov@mapbox.com>2020-02-14 17:34:00 +0200
commita876c965a55213f38b91303c81239fbda0a9f7da (patch)
tree3189f7cd15c0633a54b8220550ab3e8b28e50a75 /CMakeLists.txt
parent189ed4aac362f7122e0889cdb9c7fc6580d24392 (diff)
downloadqtlocation-mapboxgl-a876c965a55213f38b91303c81239fbda0a9f7da.tar.gz
[core] Store SegmentVectors in ephemeral render objects
We used some shared SegmentVectors, e.g. for drawing raster or background tiles. In longer running maps, this lead to resource accumulation. By storing the SegmentVectors and the contained gfx::DrawScope objects, we ensure that resources get released when the associated render objects vanish.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4509f08e73..485ced04aa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -772,8 +772,6 @@ add_library(
${PROJECT_SOURCE_DIR}/src/mbgl/util/http_timeout.hpp
${PROJECT_SOURCE_DIR}/src/mbgl/util/i18n.cpp
${PROJECT_SOURCE_DIR}/src/mbgl/util/i18n.hpp
- ${PROJECT_SOURCE_DIR}/src/mbgl/util/id.cpp
- ${PROJECT_SOURCE_DIR}/src/mbgl/util/id.hpp
${PROJECT_SOURCE_DIR}/src/mbgl/util/interpolate.cpp
${PROJECT_SOURCE_DIR}/src/mbgl/util/intersection_tests.cpp
${PROJECT_SOURCE_DIR}/src/mbgl/util/intersection_tests.hpp