summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKonstantin Käfer <mail@kkaefer.com>2018-11-16 10:53:54 +0100
committerKonstantin Käfer <mail@kkaefer.com>2018-11-28 14:49:44 +0100
commita0b8f01c1baf640f34c0f46ba22efd399b7a0012 (patch)
tree96d9cb1b5f0daaf21b2dad3d880a1dcf15dde37e /CMakeLists.txt
parent46edc91656a4468ff05f2a7b33c5fb036ab449d6 (diff)
downloadqtlocation-mapboxgl-a0b8f01c1baf640f34c0f46ba22efd399b7a0012.tar.gz
[build] use newer compiler versions for some builds
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b0de9774e1..fb00412256 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -100,6 +100,7 @@ set(CMAKE_C_FLAGS_SANITIZE "${CMAKE_C_FLAGS_SANITIZE} -O1 -g -fno-omit-frame-poi
if(CMAKE_CXX_COMPILER_ID MATCHES ".*Clang")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-error=unknown-warning-option")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-error=unknown-warning-option")
elseif(CMAKE_COMPILER_IS_GNUCXX)
# https://svn.boost.org/trac/boost/ticket/9240
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fext-numeric-literals")