summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKonstantin Käfer <mail@kkaefer.com>2019-03-13 18:35:29 +0100
committerKonstantin Käfer <mail@kkaefer.com>2019-03-13 20:42:30 +0100
commit979433eddb5a8f2180aba134befb08b222718bc8 (patch)
treea307962a9105152514b6ab37f98818b6d4431204 /CMakeLists.txt
parente9805b60ee77fcb91dcaac89c09290d185d072bd (diff)
downloadqtlocation-mapboxgl-979433eddb5a8f2180aba134befb08b222718bc8.tar.gz
[build] update Boost to 1.69 and remove RTTI
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cdd14ee10f..ca33c36be2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,6 +88,8 @@ else()
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Wshadow -Wno-variadic-macros -Wno-unknown-pragmas")
endif()
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fno-rtti")
+
if(APPLE AND CMAKE_CXX_COMPILER_ID MATCHES ".*Clang")
# -Wno-error=unused-command-line-argument is required due to https://llvm.org/bugs/show_bug.cgi?id=7798
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-error=unused-command-line-argument")