summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAnder Conselvan de Oliveira <ander.deoliveira@mapbox.com>2019-03-04 13:18:22 +0200
committerAnder Conselvan de Oliveira <ander.deoliveira@mapbox.com>2019-03-13 15:06:56 +0200
commit8afb24b539951a6b02cf9e6e41639fea1748deda (patch)
treead8aa7eeec7c73b75021d5bdbe92c29948ff1239 /CMakeLists.txt
parent7d1911572000d1353c1c0109402431323fcd8639 (diff)
downloadqtlocation-mapboxgl-8afb24b539951a6b02cf9e6e41639fea1748deda.tar.gz
[build] A build target to check for doxygen documentation coverage
Add a cmake target that builds doxygen documentation and reports on coverage using doxy-coverage. Script was copied from: https://github.com/alobbs/doxy-coverage/commit/29a0bbf43bfecb6872cdca0e4a11733954d25196
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bf7cc6465e..cdd14ee10f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,6 +38,7 @@ include(cmake/mbgl.cmake)
include(cmake/vendor.cmake)
include(cmake/mason.cmake)
include(cmake/xcode.cmake)
+include(cmake/doxygen.cmake)
if(WITH_CXX11ABI)
set(MASON_CXXABI_SUFFIX -cxx11abi)