summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKonstantin Käfer <mail@kkaefer.com>2018-08-13 16:29:14 -0700
committerKonstantin Käfer <mail@kkaefer.com>2018-08-14 17:03:46 -0700
commit6e06e55b95fdb9070d32d44786441255871dbb0b (patch)
treed9e074da720f8339966c99ded803f4f59a83b68e /CMakeLists.txt
parent89515de769aea0b54a800514f7deaf65649d9d54 (diff)
downloadqtlocation-mapboxgl-6e06e55b95fdb9070d32d44786441255871dbb0b.tar.gz
WIP: use expected<T, E> for passing on errors
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b6b86d9a8d..a02b4b9173 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -176,8 +176,10 @@ if(WITH_NODEJS AND COMMAND mbgl_platform_node)
endif()
if(CMAKE_GENERATOR STREQUAL "Xcode")
- write_xcconfig_target_properties(
- mbgl-core
- mbgl-filesource
+ set_xcconfig_target_properties(mbgl-core)
+ set_xcconfig_target_properties(mbgl-filesource)
+ file(GENERATE
+ OUTPUT "${CMAKE_BINARY_DIR}/config.xcconfig"
+ INPUT "${CMAKE_SOURCE_DIR}/scripts/config.xcconfig.in"
)
endif()