summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Shalamov <alexander.shalamov@mapbox.com>2020-04-21 21:03:48 +0300
committerThiago Marcos P. Santos <tmpsantos@gmail.com>2020-04-27 19:47:30 +0300
commit4457f5ced9e4ac2454df4c719e7e8f3e1f55b39a (patch)
treee4a8c5cf52814bd534c31e6d0b52411c06850e03 /CMakeLists.txt
parentde12a0647dd1d0681d051ff7e3797356db149a52 (diff)
downloadqtlocation-mapboxgl-4457f5ced9e4ac2454df4c719e7e8f3e1f55b39a.tar.gz
Build default http stack if MBGL_PUBLIC_BUILD is set
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6232c7df1a..fe079f6d98 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1023,6 +1023,10 @@ endif()
include(${PROJECT_SOURCE_DIR}/scripts/license.cmake)
+if(NOT EXISTS ${PROJECT_SOURCE_DIR}/internal/internal.cmake)
+ set(MBGL_PUBLIC_BUILD TRUE)
+endif()
+
if(MBGL_WITH_QT)
include(${PROJECT_SOURCE_DIR}/platform/qt/qt.cmake)
elseif(CMAKE_SYSTEM_NAME STREQUAL Android)