summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThiago Marcos P. Santos <tmpsantos@gmail.com>2020-02-24 15:49:11 +0200
committerThiago Marcos P. Santos <tmpsantos@gmail.com>2020-02-27 18:19:31 +0200
commit242b719f0cbb24b485e439edd0da5aedee87f444 (patch)
tree53455edff4a9ed6c60fddc20d060363f68709554 /CMakeLists.txt
parent1db92f3c6c8cc1977a89b2060cafef754e4dd34d (diff)
downloadqtlocation-mapboxgl-242b719f0cbb24b485e439edd0da5aedee87f444.tar.gz
[build] Generate the LICENSE.md for mbgl-core
Add a script that for everything we link against mbgl-core, it will check the license and generate a file all the dependencies listed with the respective authors, project urls and license.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 12 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 05ba29a96f..ca0fbefa74 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -933,11 +933,7 @@ target_include_directories(
PUBLIC ${PROJECT_SOURCE_DIR}/include
)
-if(NOT TARGET mapbox-base)
- add_subdirectory(${PROJECT_SOURCE_DIR}/vendor/mapbox-base/mapbox)
- add_subdirectory(${PROJECT_SOURCE_DIR}/vendor/mapbox-base/extras)
-endif()
-
+include(${PROJECT_SOURCE_DIR}/vendor/mapbox-base.cmake)
include(${PROJECT_SOURCE_DIR}/vendor/boost.cmake)
include(${PROJECT_SOURCE_DIR}/vendor/earcut.hpp.cmake)
include(${PROJECT_SOURCE_DIR}/vendor/eternal.cmake)
@@ -975,6 +971,17 @@ target_link_libraries(
Mapbox::Base::weak
)
+set_target_properties(
+ mbgl-core
+ PROPERTIES
+ INTERFACE_MAPBOX_NAME "Mapbox GL Native"
+ INTERFACE_MAPBOX_URL "https://github.com/mapbox/mapbox-gl-native"
+ INTERFACE_MAPBOX_AUTHOR "Mapbox"
+ INTERFACE_MAPBOX_LICENSE ${PROJECT_SOURCE_DIR}/LICENSE.md
+)
+
+include(${PROJECT_SOURCE_DIR}/scripts/license.cmake)
+
set_property(TARGET mbgl-core PROPERTY FOLDER Core)
add_library(