summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKonstantin Käfer <mail@kkaefer.com>2017-11-20 22:39:52 +0100
committerJohn Firebaugh <john.firebaugh@gmail.com>2018-08-27 14:07:40 -0700
commit1e454642c8bc99698d25105fe0034916e2930fe6 (patch)
tree3d9b60c1366033c97dfe51d4285d6bf3edf992ed /CMakeLists.txt
parentfd1ed8ce48fc9eaf6793e852381d8c7e648386af (diff)
downloadqtlocation-mapboxgl-1e454642c8bc99698d25105fe0034916e2930fe6.tar.gz
[build] allow WITH_EGL for macOS as well (SwiftShader) and enable EGL for GLFW
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b007b541b7..98d6676ef1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,7 +24,7 @@ if(WITH_OSMESA AND WITH_EGL)
endif()
if(WITH_EGL)
- add_definitions(-DMBGL_USE_GLES2=1)
+ set(USE_GLES2 ON)
endif()
if($ENV{CI})
@@ -144,6 +144,14 @@ endif()
include(platform/${MBGL_PLATFORM}/config.cmake)
+if(WITH_EGL)
+ add_definitions(-DMBGL_WITH_EGL=1)
+endif()
+
+if(USE_GLES2)
+ add_definitions(-DMBGL_USE_GLES2=1)
+endif()
+
if (COMMAND mbgl_filesource)
include(cmake/filesource.cmake)
endif()