summaryrefslogtreecommitdiff
path: root/src/effects/private/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/effects/private/CMakeLists.txt')
-rw-r--r--src/effects/private/CMakeLists.txt31
1 files changed, 1 insertions, 30 deletions
diff --git a/src/effects/private/CMakeLists.txt b/src/effects/private/CMakeLists.txt
index aba6f59..a75eda4 100644
--- a/src/effects/private/CMakeLists.txt
+++ b/src/effects/private/CMakeLists.txt
@@ -10,7 +10,6 @@ qt_add_qml_module(qtgraphicaleffectsprivate
CLASSNAME QtGraphicalEffectsPrivatePlugin
SOURCES
plugin.cpp
- qgfxshaderbuilder.cpp qgfxshaderbuilder_p.h
qgfxsourceproxy.cpp qgfxsourceproxy_p.h
PUBLIC_LIBRARIES
Qt::Core
@@ -25,7 +24,7 @@ qt_add_qml_module(qtgraphicaleffectsprivate
#### Keys ignored in scope 1:.:.:private.pro:<TRUE>:
# CXX_MODULE = "qml"
-# QML_FILES = "DropShadowBase.qml" "FastGlow.qml" "FastInnerShadow.qml" "FastMaskedBlur.qml" "GaussianDirectionalBlur.qml" "GaussianGlow.qml" "GaussianInnerShadow.qml" "GaussianMaskedBlur.qml"
+# QML_FILES = "FastGlow.qml"
# QML_IMPORT_VERSION = "$$QT_VERSION"
# TARGETPATH = "QtGraphicalEffects/private"
@@ -33,39 +32,11 @@ qt_add_qml_module(qtgraphicaleffectsprivate
#####################################################################
set(qml_files
- "DropShadowBase.qml"
"FastGlow.qml"
- "FastInnerShadow.qml"
- "FastMaskedBlur.qml"
- "GaussianDirectionalBlur.qml"
- "GaussianGlow.qml"
- "GaussianInnerShadow.qml"
- "GaussianMaskedBlur.qml"
-)
-set_source_files_properties(DropShadowBase.qml PROPERTIES
- QT_QML_SOURCE_VERSION "1.0"
)
set_source_files_properties(FastGlow.qml PROPERTIES
QT_QML_SOURCE_VERSION "1.0"
)
-set_source_files_properties(FastInnerShadow.qml PROPERTIES
- QT_QML_SOURCE_VERSION "1.0"
-)
-set_source_files_properties(FastMaskedBlur.qml PROPERTIES
- QT_QML_SOURCE_VERSION "1.0"
-)
-set_source_files_properties(GaussianDirectionalBlur.qml PROPERTIES
- QT_QML_SOURCE_VERSION "1.0"
-)
-set_source_files_properties(GaussianGlow.qml PROPERTIES
- QT_QML_SOURCE_VERSION "1.0"
-)
-set_source_files_properties(GaussianInnerShadow.qml PROPERTIES
- QT_QML_SOURCE_VERSION "1.0"
-)
-set_source_files_properties(GaussianMaskedBlur.qml PROPERTIES
- QT_QML_SOURCE_VERSION "1.0"
-)
qt6_target_qml_files(qtgraphicaleffectsprivate
FILES