summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 19d18e6..e7de02e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,8 +2,9 @@
cmake_minimum_required(VERSION 3.15.0)
+include(.cmake.conf)
project(QtGraphicalEffects # special case
- VERSION 6.0.0
+ VERSION "${QT_REPO_MODULE_VERSION}"
DESCRIPTION "Qt Graphical Effects" # special case
HOMEPAGE_URL "https://qt.io/"
LANGUAGES CXX C
@@ -15,8 +16,4 @@ if(NOT TARGET Qt::Quick)
message(NOTICE "Skipping the build as the condition \"TARGET Qt::Quick\" is not met.")
return()
endif()
-if(NOT QT_FEATURE_opengl) # special case
- message(NOTICE "Skipping the build as the condition \"QT_FEATURE_opengl\" is not met.") # special case
- return()
-endif()
qt_build_repo()