summaryrefslogtreecommitdiff
path: root/examples/opengl/threadedqopenglwidget/CMakeLists.txt
diff options
context:
space:
mode:
authorLaszlo Agocs <laszlo.agocs@qt.io>2023-02-27 12:37:30 +0100
committerLaszlo Agocs <laszlo.agocs@qt.io>2023-02-28 14:28:51 +0100
commit6462a454e3d53c3711817b510cff59c136711b9e (patch)
tree29afaf653198da1e8eac0d15f2a878fb947abc0c /examples/opengl/threadedqopenglwidget/CMakeLists.txt
parent86a517ac786c90b9ce8deb502c413287e31058c2 (diff)
downloadqtbase-6462a454e3d53c3711817b510cff59c136711b9e.tar.gz
Remove threadeqopenglwidget example
It is neither documented nor very useful, and it has platform-specific issues as reported over the years. Remove it now as part of the example revamp initiative. Task-number: QTBUG-50278 Task-number: QTBUG-110093 Task-number: QTBUG-76054 Task-number: QTBUG-43209 Pick-to: 6.5 Change-Id: I6dadaf4162b4c19411c544b9f204c19e37aa740d Reviewed-by: Eirik Aavitsland <eirik.aavitsland@qt.io>
Diffstat (limited to 'examples/opengl/threadedqopenglwidget/CMakeLists.txt')
-rw-r--r--examples/opengl/threadedqopenglwidget/CMakeLists.txt41
1 files changed, 0 insertions, 41 deletions
diff --git a/examples/opengl/threadedqopenglwidget/CMakeLists.txt b/examples/opengl/threadedqopenglwidget/CMakeLists.txt
deleted file mode 100644
index 6efecc4d07..0000000000
--- a/examples/opengl/threadedqopenglwidget/CMakeLists.txt
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: BSD-3-Clause
-
-cmake_minimum_required(VERSION 3.16)
-project(threadedqopenglwidget LANGUAGES CXX)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/opengl/threadedqopenglwidget")
-
-find_package(Qt6 REQUIRED COMPONENTS Core Gui OpenGL OpenGLWidgets Widgets)
-
-qt_standard_project_setup()
-
-qt_add_executable(threadedqopenglwidget
- renderer.cpp renderer.h
- glwidget.cpp glwidget.h
- main.cpp
- mainwindow.cpp mainwindow.h
-)
-
-set_target_properties(threadedqopenglwidget PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-
-target_link_libraries(threadedqopenglwidget PRIVATE
- Qt6::Core
- Qt6::Gui
- Qt6::OpenGL
- Qt6::OpenGLWidgets
- Qt6::Widgets
-)
-
-install(TARGETS threadedqopenglwidget
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)