summaryrefslogtreecommitdiff
path: root/tests/auto/yaml/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/yaml/CMakeLists.txt')
-rw-r--r--tests/auto/yaml/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/tests/auto/yaml/CMakeLists.txt b/tests/auto/yaml/CMakeLists.txt
new file mode 100644
index 00000000..74d63318
--- /dev/null
+++ b/tests/auto/yaml/CMakeLists.txt
@@ -0,0 +1,34 @@
+
+qt_internal_add_test(tst_yaml
+ SOURCES
+ ../error-checking.h
+ tst_yaml.cpp
+ DEFINES
+ AM_TESTDATA_DIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/../../data/\\\"
+ PUBLIC_LIBRARIES
+ Qt::Network
+ Qt::AppManCommonPrivate
+)
+
+# Resources:
+set(qmake_immediate_resource_files
+ "data/cache1.yaml"
+ "data/cache2.yaml"
+ "data/test.yaml"
+)
+
+qt_internal_add_resource(tst_yaml "qmake_immediate"
+ PREFIX
+ "/"
+ FILES
+ ${qmake_immediate_resource_files}
+)
+
+
+## Scopes:
+#####################################################################
+
+qt_internal_extend_target(tst_yaml CONDITION TARGET Qt::DBus
+ PUBLIC_LIBRARIES
+ Qt::DBus
+)