summaryrefslogtreecommitdiff
path: root/examples/applicationmanager/custom-appman/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/applicationmanager/custom-appman/CMakeLists.txt')
-rw-r--r--examples/applicationmanager/custom-appman/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/applicationmanager/custom-appman/CMakeLists.txt b/examples/applicationmanager/custom-appman/CMakeLists.txt
index c3627257..972295d4 100644
--- a/examples/applicationmanager/custom-appman/CMakeLists.txt
+++ b/examples/applicationmanager/custom-appman/CMakeLists.txt
@@ -20,6 +20,10 @@ find_package(Qt6 COMPONENTS AppManMainPrivate)
qt_add_executable(custom-appman
custom-appman.cpp
)
+
+# This define flags us as an "appman" and allows us to link against the AppMan's private libraries
+target_compile_definitions(custom-appman PRIVATE AM_COMPILING_APPMAN)
+
set_target_properties(custom-appman PROPERTIES
WIN32_EXECUTABLE FALSE
MACOSX_BUNDLE FALSE