summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTopi Reinio <topi.reinio@qt.io>2021-10-19 13:26:35 +0200
committerTopi Reinio <topi.reinio@qt.io>2021-12-11 14:31:33 +0100
commitd3ecedc2ccb228f9d125ab4870cf1a36b60fc012 (patch)
tree6cfcd556c63dcba95ade3a9a29c79aa882b7d44f /CMakeLists.txt
parente655f44896ab1a25bf0864174e14bd257323d483 (diff)
downloadqtapplicationmanager-d3ecedc2ccb228f9d125ab4870cf1a36b60fc012.tar.gz
Doc: Fix online documentation build
Select the correct documentation template if QT_BUILD_ONLINE_DOCS is set, and add a sidebar for the online doc set. Pick-to: 6.2 Change-Id: I2f7761a364e2a4cf55a4a0b6a4f9bb5f61fae3cf Reviewed-by: Nicholas Bennett <nicholas.bennett@qt.io> Reviewed-by: Robert Griebl <robert.griebl@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f2236c03..c34c848c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -102,13 +102,19 @@ qt_build_repo()
file(GLOB_RECURSE allDocFiles "doc/*.qdoc" "doc/*.png" "doc/*.qdocconf")
+if(QT_BUILD_ONLINE_DOCS)
+ set(DOC_CONF "doc/online/qtapplicationmanager.qdocconf")
+else()
+ set(DOC_CONF "doc/qtapplicationmanager.qdocconf")
+endif()
+
add_custom_target(Documentation SOURCES
doc/QtApplicationManagerDoc
${allDocFiles}
)
qt_internal_add_docs(Documentation
- doc/qtapplicationmanager.qdocconf
+ ${DOC_CONF}
)
file(GLOB licenses "LICENSE.*[^~]")