summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDominik Holland <dominik.holland@qt.io>2021-06-25 14:51:53 +0200
committerDominik Holland <dominik.holland@qt.io>2021-06-30 13:57:41 +0200
commit649a75cd251c39aee7c8c5f69825ce9e64af32de (patch)
tree8723a06c13c51c8c1633920a450a185feaa57e45 /CMakeLists.txt
parentcd088bb1b7c305e3455bc19a416d29c1cffc3b9e (diff)
downloadqtapplicationmanager-649a75cd251c39aee7c8c5f69825ce9e64af32de.tar.gz
Add support for running qml-only autotests
This adds a new qt_am_internal_add_qml_test function which takes care to create the wrappers for all configurations we want to test. Change-Id: I717cb5aff20ef5aa9ad156d9531a29c547f5d836 Reviewed-by: Robert Griebl <robert.griebl@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 00486023..c350b52f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -36,6 +36,8 @@ find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS
DltLogging
)
+include(src/main-lib/Qt6AppManMainPrivateMacros.cmake)
+
if(NOT TARGET Qt::Gui OR NOT TARGET Qt::Quick)
message(NOTICE "Skipping the build as QtGui and/or QtQuick are not available.")
return()