summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Griebl <robert.griebl@qt.io>2021-06-24 16:49:33 +0200
committerRobert Griebl <robert.griebl@qt.io>2021-06-26 22:10:08 +0200
commit0d9fee3846c661ec833d09f82b140192c6bf24ac (patch)
tree711bb7eb197190de96f03e149de419df29925d78 /CMakeLists.txt
parentff75141b0c11fdc9b60f1304cc4b1fe60e4e995f (diff)
downloadqtapplicationmanager-0d9fee3846c661ec833d09f82b140192c6bf24ac.tar.gz
cmake: Re-enable and fix the doc target
Also re-added the hardware-id configuration. Change-Id: I8f5aeba91f8dc6c9cec13eb8f9ffe48b94208ac9 Reviewed-by: Dominik Holland <dominik.holland@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0a4505f2..c6aabfef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -42,3 +42,9 @@ if(NOT TARGET Qt::Gui OR NOT TARGET Qt::Quick)
endif()
qt_build_repo()
+
+add_custom_target(QtApplicationManagerDoc)
+
+qt_internal_add_docs(QtApplicationManagerDoc
+ doc/qtapplicationmanager.qdocconf
+)