summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Griebl <robert.griebl@qt.io>2021-08-15 00:38:57 +0200
committerRobert Griebl <robert.griebl@qt.io>2021-08-20 13:17:55 +0200
commit0176865f0b20e26608e724970c1bd394d5a134b3 (patch)
treec9cf508f8a579cbb04f26cc9f57804dcb346c13a /CMakeLists.txt
parent35ee44b55bab921e2366b1bee3571d280b4f9829 (diff)
downloadqtapplicationmanager-0176865f0b20e26608e724970c1bd394d5a134b3.tar.gz
Clazy: fix src
Change-Id: I043882780fac7bed5d9dd75424ede46b54caa187 Reviewed-by: Dominik Holland <dominik.holland@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f00cf678..8b5fa6f2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,11 @@ project(QtApplicationManager # special case
)
set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
+add_compile_definitions(
+ QT_STRICT_ITERATORS
+ QT_NO_CAST_TO_ASCII
+ QT_NO_CAST_FROM_ASCII
+)
# populate the platform check variables
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals)