summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2021-04-13 18:23:54 +0200
committerAlexey Edelev <alexey.edelev@qt.io>2021-04-27 15:54:16 +0200
commitf85cb33f0e9896a39ef1a7605db379178dbef112 (patch)
tree27a8d63f5b9468096401a521730a0485822081a6 /CMakeLists.txt
parentc4623d4296f0a5502cba5f2395b97bd28a83dd6f (diff)
downloadqtactiveqt-f85cb33f0e9896a39ef1a7605db379178dbef112.tar.gz
Implement CMake functions to work with IDC
In qmake we have an implicit execution of IDC in case the axserver config is enabled. This quite difficult to implement using CMake. This adds the following CMake functions to work with IDC: - The qt6_add_axserver_executable function adds axserver executable, generates IDL file and link the produced .tbl to the executable. - The qt6_add_axserver_library function adds axserver library, generates IDL file and link the produced .tbl to the dll. - The qt6_target_idl generates IDL file and link the produced .tbl to the executable for the existing target. This also introduces the QT_SKIP_AX_SERVER_REGISTRATION variable, which disables global registration of ActiveX servers. Change-Id: I5695db9d67dac07747894fd4bb37c3e6db408035 Reviewed-by: Oliver Wolff <oliver.wolff@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 090750b..b07cfd4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,5 +35,6 @@ if(NOT TARGET Qt::Gui OR NOT TARGET Qt::Widgets OR NOT TARGET Qt::PrintSupport)
endif()
include("${CMAKE_CURRENT_SOURCE_DIR}/src/activeqt/container/Qt6AxContainerMacros.cmake")
+include("${CMAKE_CURRENT_SOURCE_DIR}/src/activeqt/control/Qt6AxServerMacros.cmake")
qt_build_repo()