summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTopi Reinio <topi.reinio@qt.io>2021-03-11 20:49:21 +0100
committerTopi Reiniƶ <topi.reinio@qt.io>2021-03-15 10:06:51 +0000
commit03de877ae8e9da3b2d7b06268a5a2c1156ee50ee (patch)
treebdaf2c50a8b6881a5fbe49962320f3a29f08e750 /CMakeLists.txt
parent2b605d7bb6f5a91bed0cbee338b5bf52b66fa88e (diff)
downloadqtactiveqt-03de877ae8e9da3b2d7b06268a5a2c1156ee50ee.tar.gz
Enable documentation build on non-Windows platforms
Pick-to: 6.1 Task-number: QTBUG-91743 Change-Id: I278397bf26b8e11076530cb341420f72bda8a435 Reviewed-by: Paul Wicking <paul.wicking@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8226e14..392016c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,18 @@ project(QtActiveQt # special case
LANGUAGES CXX C
)
+if (NOT WIN32)
+ message(NOTICE "Condition \"WIN32\" is not met, enabling documentation build only.")
+ # special case begin
+ set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
+ find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals)
+ qt_build_repo_begin()
+ add_subdirectory(src/activeqt/doc)
+ qt_build_repo_end()
+ # special case end
+ return()
+endif()
+
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core) # special case
find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Qml Quick Gui Widgets PrintSupport) # special case