summaryrefslogtreecommitdiff
path: root/src/libs/sqlite/CMakeLists.txt
diff options
context:
space:
mode:
authorMarco Bubke <marco.bubke@qt.io>2021-12-14 13:36:23 +0100
committerMarco Bubke <marco.bubke@qt.io>2021-12-14 16:50:10 +0000
commitad505aad5936fdf2eaf29dd91731e0900d1ab6d9 (patch)
treea6a7448a5f936991bb6f3de169afeb638ae4e54f /src/libs/sqlite/CMakeLists.txt
parent90bb92f327d73b8d8b563acfcab746025949f73b (diff)
downloadqt-creator-ad505aad5936fdf2eaf29dd91731e0900d1ab6d9.tar.gz
Sqlite: Strict table supportv6.0.1
With Sqlite 3.37 strict tables are introduced: https://www.sqlite.org/stricttables.html The introduce strict column types. So you can not add a text to an integer column anymore. Additionally they introduce the "any" column which is a dynamic type. Change-Id: I43c0410821aa154e7de83e24bd221a232f98e910 Reviewed-by: Tim Jenssen <tim.jenssen@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'src/libs/sqlite/CMakeLists.txt')
-rw-r--r--src/libs/sqlite/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/libs/sqlite/CMakeLists.txt b/src/libs/sqlite/CMakeLists.txt
index c200933925..3ad2d371e8 100644
--- a/src/libs/sqlite/CMakeLists.txt
+++ b/src/libs/sqlite/CMakeLists.txt
@@ -14,7 +14,7 @@ add_qtc_library(Sqlite
../3rdparty/sqlite/config.h
../3rdparty/sqlite/sqlite.h
constraints.h
- createtablesqlstatementbuilder.cpp createtablesqlstatementbuilder.h
+ createtablesqlstatementbuilder.h
lastchangedrowid.h
sqlitealgorithms.h
sqlitebasestatement.cpp sqlitebasestatement.h