summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDavid Alfonso <developer@davidalfonso.es>2019-10-09 11:08:39 +0200
committerDavid Alfonso <developer@davidalfonso.es>2019-10-09 16:25:59 +0200
commitbc450b3339d9eb4ce4649a5989836dcee496688f (patch)
tree7a622d3749e55dbe732f0a1aac4241c3c66d75c0 /setup.py
parent7aa2f6c14246a1254416921dd1c7b7a8debdb63c (diff)
downloadpelican-bc450b3339d9eb4ce4649a5989836dcee496688f.tar.gz
Add extra/optional Markdown dependency to setup.py
- Modify documentation to use the extra dependency in order to install the recommended markdown package version.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 5eea85b6..0979d1c4 100755
--- a/setup.py
+++ b/setup.py
@@ -61,6 +61,9 @@ setup(
for name in names],
},
install_requires=requires,
+ extras_require={
+ 'Markdown': ['markdown~=3.1.1']
+ },
entry_points=entry_points,
classifiers=[
'Development Status :: 5 - Production/Stable',