summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJustin Mayer <entroP@gmail.com>2020-11-02 13:17:53 +0100
committerJustin Mayer <entroP@gmail.com>2020-11-02 13:17:53 +0100
commitb454f76f72dea65db9d360dc1bf51b8ddb76149d (patch)
tree93a534ac65cf0bdf0ecb681048e649f14ca569ca /pyproject.toml
parentc345268de6b754d31dbae67d0fc23efc0db5e6fe (diff)
downloadpelican-b454f76f72dea65db9d360dc1bf51b8ddb76149d.tar.gz
Count CPU cores via psutil for parallel testing
psutil does a much better job at accurately counting CPU cores, of which pytest-xdist takes advantage for the purposes of running tests concurrently.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 1cf84312..cbe7642e 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -49,6 +49,7 @@ typogrify = "^2.0"
sphinx = "^3.0"
sphinx_rtd_theme = "^0.5"
livereload = "^2.6"
+psutil = {version = "^5.7", optional = true}
pytest = "^6.0"
pytest-cov = "^2.8"
pytest-pythonpath = "^0.7.3"