summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Kolbe <jk@gocept.com>2018-10-05 10:05:05 +0200
committerJeremy Kolbe <jk@gocept.com>2018-10-05 10:05:05 +0200
commit350dd763e62d14e2eae02b8603a55086a267d11f (patch)
treeb602f9b9303febbbaba9e11bb339fe3cefc4d991
parent35a62f9036a7a4e492867d76f8b335086ad4512a (diff)
downloadzope-traversing-Python3.7support.tar.gz
Add support for Python 3.7Python3.7support
-rw-r--r--.travis.yml13
-rw-r--r--CHANGES.rst3
-rw-r--r--setup.py1
-rw-r--r--tox.ini6
4 files changed, 13 insertions, 10 deletions
diff --git a/.travis.yml b/.travis.yml
index b07bcf7..80e6fd7 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -5,12 +5,13 @@ python:
- 3.4
- 3.5
- 3.6
- # Force a newer PyPy on the old 'precise' CI image
- # in order to install 'cryptography' needed for coveralls
- # After September 2017 this should be the default and the version
- # pin can be removed.
- - pypy-5.6.0
- - pypy3.5-5.8.0
+ - pypy
+ - pypy3
+matrix:
+ include:
+ - python: "3.7"
+ dist: xenial
+ sudo: true
install:
- pip install -U pip setuptools
- pip install -U coverage coveralls
diff --git a/CHANGES.rst b/CHANGES.rst
index a95e93d..c3a2e99 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -5,8 +5,9 @@
4.2.1 (unreleased)
==================
-- Host documentation at https://zopetraversing.readthedocs.io/
+- Add support for Python 3.7.
+- Host documentation at https://zopetraversing.readthedocs.io
4.2.0 (2017-09-23)
==================
diff --git a/setup.py b/setup.py
index ed864fb..391dc2b 100644
--- a/setup.py
+++ b/setup.py
@@ -63,6 +63,7 @@ setup(
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
diff --git a/tox.ini b/tox.ini
index df2a65d..fd0ceb6 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py27,py34,py35,py36,pypy,pypy3,coverage,docs
+ py27,py34,py35,py36,py37,pypy,pypy3,coverage,docs
[testenv]
commands =
@@ -11,7 +11,7 @@ deps =
[testenv:coverage]
usedevelop = true
basepython =
- python2.7
+ python3.7
commands =
coverage run -m zope.testrunner --test-path=src []
coverage report --fail-under=100
@@ -21,7 +21,7 @@ deps =
[testenv:docs]
basepython =
- python2.7
+ python3.6
commands =
sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
deps =