summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Kolbe <jk@gocept.com>2018-10-05 11:21:34 +0200
committerJeremy Kolbe <jk@gocept.com>2018-10-05 11:21:34 +0200
commit109d7dd195c31754ca55c761fb3b11f4176d2372 (patch)
tree671bbe4a8c4f648f4b32634cf34f4308ea71f180
parent527eaa3f626c6f7637f43b32889e7c742a71fe23 (diff)
downloadzope-tales-Python3.7support.tar.gz
Add support for Python 3.7Python3.7support
-rw-r--r--.travis.yml5
-rw-r--r--CHANGES.rst3
-rw-r--r--setup.py1
-rw-r--r--tox.ini6
4 files changed, 11 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
index e903051..80e6fd7 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -7,6 +7,11 @@ python:
- 3.6
- pypy
- pypy3
+matrix:
+ include:
+ - python: "3.7"
+ dist: xenial
+ sudo: true
install:
- pip install -U pip setuptools
- pip install -U coverage coveralls
diff --git a/CHANGES.rst b/CHANGES.rst
index 7e55b33..25fa4ad 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -5,8 +5,9 @@
4.2.1 (unreleased)
==================
-- Host documentation at https://zopetales.readthedocs.io
+- Add support for Python 3.7.
+- Host documentation at https://zopetales.readthedocs.io
4.2.0 (2017-09-22)
==================
diff --git a/setup.py b/setup.py
index 790bc09..3c68efd 100644
--- a/setup.py
+++ b/setup.py
@@ -55,6 +55,7 @@ setup(name='zope.tales',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
diff --git a/tox.ini b/tox.ini
index 3d18895..fd0ceb6 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py27,py34,py35,py36,pypy,pypy3,coverage,docs
+ py27,py34,py35,py36,py37,pypy,pypy3,coverage,docs
[testenv]
commands =
@@ -11,7 +11,7 @@ deps =
[testenv:coverage]
usedevelop = true
basepython =
- python3.6
+ python3.7
commands =
coverage run -m zope.testrunner --test-path=src []
coverage report --fail-under=100
@@ -21,7 +21,7 @@ deps =
[testenv:docs]
basepython =
- python2.7
+ python3.6
commands =
sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
deps =