summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini10
1 files changed, 4 insertions, 6 deletions
diff --git a/tox.ini b/tox.ini
index 1a61904..4ef11c7 100644
--- a/tox.ini
+++ b/tox.ini
@@ -10,6 +10,7 @@ envlist =
py37
py38
py39
+ py310
pypy
pypy3
docs
@@ -18,7 +19,6 @@ envlist =
[testenv]
usedevelop = true
deps =
- zope.testrunner
commands =
zope-testrunner --test-path=src {posargs:-vc}
extras =
@@ -30,7 +30,8 @@ skip_install = true
deps =
flake8
check-manifest
- check-python-versions
+ check-python-versions >= 0.19.1
+ wheel
commands =
flake8 src setup.py
check-manifest
@@ -39,8 +40,6 @@ commands =
[testenv:docs]
basepython = python3
skip_install = false
-# Until repoze.sphinx.autointerface supports Sphinx 4.x we cannot use it:
-deps = Sphinx < 4
extras =
docs
commands_pre =
@@ -54,7 +53,6 @@ allowlist_externals =
deps =
coverage
coverage-python-version
- zope.testrunner
commands =
mkdir -p {toxinidir}/parts/htmlcov
coverage run -m zope.testrunner --test-path=src {posargs:-vc}
@@ -64,7 +62,7 @@ commands =
[coverage:run]
branch = True
plugins = coverage_python_version
-source = src
+source = zope.tal
[coverage:report]
precision = 2