summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Yan <felixonmars@archlinux.org>2015-11-13 13:50:51 +0800
committerFelix Yan <felixonmars@archlinux.org>2015-11-13 13:50:51 +0800
commited08119e604de93a738b1acb0790793a64688828 (patch)
tree1625475296350c619b70f7ea11ffd07465d40e5c
parent3e48d6c2df25101e9865921b4aff49aa7972b624 (diff)
downloadzope-tal-ed08119e604de93a738b1acb0790793a64688828.tar.gz
Note explicit support for Python 3.5
-rw-r--r--.travis.yml4
-rw-r--r--CHANGES.rst2
-rw-r--r--README.rst4
-rw-r--r--setup.py1
-rw-r--r--tox.ini2
5 files changed, 12 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index cc456fb..e06867a 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,5 +1,9 @@
language: python
sudo: false
+matrix:
+ include:
+ - python: 3.5
+ env: TOXENV=py35
env:
- TOXENV=py26
- TOXENV=py27
diff --git a/CHANGES.rst b/CHANGES.rst
index ad2284c..fd9673a 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -7,6 +7,8 @@ Changes
- Accept and ignore ``i18n:ignore`` and ``i18n:ignore-attributes`` attributes.
For compatibility with other tools (such as ``i18ndude``).
+- Claim support for Python 3.5.
+
4.1.1 (2015-06-05)
------------------
diff --git a/README.rst b/README.rst
index 99e3978..e40e341 100644
--- a/README.rst
+++ b/README.rst
@@ -1,6 +1,10 @@
``zope.tal``
============
+.. image:: https://img.shields.io/pypi/v/zope.tal.svg
+ :target: https://pypi.python.org/pypi/zope.tal/
+ :alt: Latest Version
+
.. image:: https://travis-ci.org/zopefoundation/zope.tal.png?branch=master
:target: https://travis-ci.org/zopefoundation/zope.tal
diff --git a/setup.py b/setup.py
index 93301d8..b87af8e 100644
--- a/setup.py
+++ b/setup.py
@@ -66,6 +66,7 @@ setup(name='zope.tal',
'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
diff --git a/tox.ini b/tox.ini
index 09ae62a..f0a2a56 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py26,py27,py32,py33,py34,pypy,pypy3,coverage
+ py26,py27,py32,py33,py34,py35,pypy,pypy3,coverage
[testenv]
commands =