summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2016-03-23 18:02:56 -0400
committerTres Seaver <tseaver@palladion.com>2016-03-23 18:02:56 -0400
commitf5c4e00f3b50208bc035f140696061d17a9acb76 (patch)
tree092a051ca731e3d41393f6c40e2d529098e7c2bc
parent65009b236143ae0d0a000f816a2fc2d1862d1a75 (diff)
downloadzope-tal-drop-py26-py32-support.tar.gz
Drop support for Python 2.6 and 3.2.drop-py26-py32-support
-rw-r--r--.travis.yml2
-rw-r--r--CHANGES.rst6
-rw-r--r--setup.py4
-rw-r--r--tox.ini2
4 files changed, 6 insertions, 8 deletions
diff --git a/.travis.yml b/.travis.yml
index e06867a..5dd4fef 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -5,9 +5,7 @@ matrix:
- python: 3.5
env: TOXENV=py35
env:
- - TOXENV=py26
- TOXENV=py27
- - TOXENV=py32
- TOXENV=py33
- TOXENV=py34
- TOXENV=pypy
diff --git a/CHANGES.rst b/CHANGES.rst
index fd9673a..2bc1e5f 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,13 +1,15 @@
Changes
=======
-4.1.2 (unreleased)
+4.2.0 (unreleased)
------------------
+- Drop support for Python 2.6 and 3.2.
+
- Accept and ignore ``i18n:ignore`` and ``i18n:ignore-attributes`` attributes.
For compatibility with other tools (such as ``i18ndude``).
-- Claim support for Python 3.5.
+- Add support for Python 3.5.
4.1.1 (2015-06-05)
------------------
diff --git a/setup.py b/setup.py
index b87af8e..31c5e16 100644
--- a/setup.py
+++ b/setup.py
@@ -43,7 +43,7 @@ def alltests():
return TestSuite(suites)
setup(name='zope.tal',
- version='4.1.2.dev0',
+ version='4.2.0.dev0',
author='Zope Foundation and Contributors',
author_email='zope-dev@zope.org',
description='Zope Template Application Language (TAL)',
@@ -60,10 +60,8 @@ setup(name='zope.tal',
'License :: OSI Approved :: Zope Public License',
'Programming Language :: Python',
'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
diff --git a/tox.ini b/tox.ini
index f0a2a56..1c2eb66 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py26,py27,py32,py33,py34,py35,pypy,pypy3,coverage
+ py27,py33,py34,py35,pypy,pypy3,coverage
[testenv]
commands =