summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Kolbe <jk@gocept.com>2018-10-05 11:33:20 +0200
committerJeremy Kolbe <jk@gocept.com>2018-10-05 11:33:20 +0200
commitda707810688c0343fce05d4454ad9fe529c418bf (patch)
tree5bc1f011b12afab0b4d0ca75304c5f4437c19251
parent11ecfeb040638c7f652d1cadbaee40091d74e63f (diff)
downloadzope-tal-Python3.7support.tar.gz
Add support for python 3.7Python3.7support
-rw-r--r--.travis.yml7
-rw-r--r--CHANGES.rst3
-rw-r--r--setup.py1
-rw-r--r--tox.ini6
4 files changed, 11 insertions, 6 deletions
diff --git a/.travis.yml b/.travis.yml
index f44d718..80e6fd7 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -6,7 +6,12 @@ python:
- 3.5
- 3.6
- pypy
- - pypy3.5-5.8.0
+ - pypy3
+matrix:
+ include:
+ - python: "3.7"
+ dist: xenial
+ sudo: true
install:
- pip install -U pip setuptools
- pip install -U coverage coveralls
diff --git a/CHANGES.rst b/CHANGES.rst
index 1b792a2..9fdbf0b 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -5,8 +5,7 @@
4.3.2 (unreleased)
==================
-- Nothing changed yet.
-
+- Add support for Python 3.7.
4.3.1 (2018-03-21)
==================
diff --git a/setup.py b/setup.py
index 17b7dea..eb32df2 100644
--- a/setup.py
+++ b/setup.py
@@ -70,6 +70,7 @@ setup(name='zope.tal',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Natural Language :: English',
diff --git a/tox.ini b/tox.ini
index 4d45658..f15678e 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py27,py34,py35,py36,pypy,pypy3,coverage,docs
+ py27,py34,py35,py36,py37,pypy,pypy3,coverage,docs
[testenv]
commands =
@@ -11,7 +11,7 @@ deps =
[testenv:coverage]
usedevelop = true
basepython =
- python2.7
+ python3.7
commands =
coverage run -m zope.testrunner --test-path=src
coverage report --fail-under=87
@@ -21,7 +21,7 @@ deps =
[testenv:docs]
basepython =
- python2.7
+ python3.6
commands =
sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
deps =