summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini18
1 files changed, 14 insertions, 4 deletions
diff --git a/tox.ini b/tox.ini
index 7c625bd..8931aaa 100644
--- a/tox.ini
+++ b/tox.ini
@@ -11,6 +11,7 @@ envlist =
py38,py38-pure
py39,py39-pure
py310,py310-pure
+ py311,py311-pure
pypy
pypy3
docs
@@ -19,6 +20,7 @@ envlist =
[testenv]
usedevelop = true
+pip_pre = true
deps =
setenv =
pure: PURE_PYTHON=1
@@ -49,15 +51,23 @@ commands =
[testenv:lint]
basepython = python3
skip_install = true
+commands =
+ check-manifest
+ check-python-versions
deps =
- flake8
check-manifest
check-python-versions >= 0.19.1
wheel
+ flake8
+ isort
+
+[testenv:isort-apply]
+basepython = python3
+commands_pre =
+deps =
+ isort
commands =
- flake8 src setup.py
- check-manifest
- check-python-versions
+ isort {toxinidir}/src {toxinidir}/setup.py []
[testenv:docs]
basepython = python3