summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini73
1 files changed, 51 insertions, 22 deletions
diff --git a/tox.ini b/tox.ini
index 1a7a0ee..7c625bd 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,39 +1,68 @@
+# Generated from:
+# https://github.com/zopefoundation/meta/tree/master/config/c-code
[tox]
+minversion = 3.18
envlist =
-# Jython support pending 2.7 support, due 2012-07-15 or so. See:
-# http://fwierzbicki.blogspot.com/2012/03/adconion-to-fund-jython-27.html
-# py27,pypy,jython,py33,coverage,docs
- py27,py27-watch,pypy,pypy3,py35,py36,py37-watch,py37-pure,py37,py38,coverage,docs
+ lint
+ py27,py27-pure
+ py35,py35-pure
+ py36,py36-pure
+ py37,py37-pure
+ py38,py38-pure
+ py39,py39-pure
+ py310,py310-pure
+ pypy
+ pypy3
+ docs
+ coverage
+ py27-watch, py37-watch
[testenv]
+usedevelop = true
+deps =
+setenv =
+ pure: PURE_PYTHON=1
+ !pure-!pypy-!pypy3: PURE_PYTHON=0
+ ZOPE_INTERFACE_STRICT_IRO=1
+ watch: ZOPE_WATCH_CHECKERS = 1
commands =
- zope-testrunner --test-path=src []
- sphinx-build -b doctest -d {envdir}/.cache/doctrees docs {envdir}/.cache/doctest
+ zope-testrunner --test-path=src {posargs:-vc}
+ !py27-!pypy: sphinx-build -b doctest -d {envdir}/.cache/doctrees docs {envdir}/.cache/doctest
extras =
test
docs
-deps =
-setenv =
- ZOPE_INTERFACE_STRICT_IRO = 1
- watch: ZOPE_WATCH_CHECKERS = 1
- pure: PURE_PYTHON = 1
[testenv:coverage]
-usedevelop = true
-basepython =
- python2.7
-commands =
- coverage run -m zope.testrunner --test-path=src []
- coverage run -a -m sphinx -b doctest -d {envdir}/.cache/doctrees docs {envdir}/.cache/doctest
- coverage html
- coverage report --fail-under=100
+basepython = python3
+allowlist_externals =
+ mkdir
deps =
- {[testenv]deps}
coverage
+setenv =
+ PURE_PYTHON=1
+commands =
+ mkdir -p {toxinidir}/parts/htmlcov
+ coverage run -m zope.testrunner --test-path=src {posargs:-vc}
+ coverage html -i
+ coverage report -i -m --fail-under=99.5
+
+[testenv:lint]
+basepython = python3
+skip_install = true
+deps =
+ flake8
+ check-manifest
+ check-python-versions >= 0.19.1
+ wheel
+commands =
+ flake8 src setup.py
+ check-manifest
+ check-python-versions
[testenv:docs]
-basepython =
- python3.7
+basepython = python3
+skip_install = false
+commands_pre =
commands =
sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
sphinx-build -b doctest -d docs/_build/doctrees docs docs/_build/doctest