summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.github/workflows/tests.yml54
-rwxr-xr-x.manylinux-install.sh6
-rw-r--r--.meta.toml2
-rw-r--r--appveyor.yml2
-rw-r--r--tox.ini4
5 files changed, 37 insertions, 31 deletions
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index ea9d246..7a18d35 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -95,22 +95,23 @@ jobs:
fail-fast: false
matrix:
python-version:
- - 2.7
- - 3.5
- - pypy-2.7
- - pypy-3.6
- - 3.6
- - 3.7
- - 3.8
- - 3.9
+ - "2.7"
+ - "3.5"
+ - "pypy-2.7"
+ - "pypy-3.7"
+ - "3.6"
+ - "3.7"
+ - "3.8"
+ - "3.9"
+ - "3.10"
os: [ubuntu-20.04, macos-latest]
exclude:
- os: macos-latest
- python-version: pypy-2.7
+ python-version: "pypy-2.7"
- os: macos-latest
- python-version: pypy-3.6
+ python-version: "pypy-3.7"
- os: macos-latest
- python-version: 3.5
+ python-version: "3.5"
steps:
- name: checkout
@@ -168,7 +169,7 @@ jobs:
# We cannot 'uses: pypa/gh-action-pypi-publish@v1.4.1' because
# that's apparently a container action, and those don't run on
# the Mac.
- if: github.event_name == 'push' && startsWith(github.ref, 'refs/tags') && startsWith(runner.os, 'Mac')
+ if: github.event_name == 'push' && startsWith(github.ref, 'refs/tags') && startsWith(runner.os, 'Mac') && !startsWith(matrix.python-version, 'pypy')
env:
TWINE_PASSWORD: ${{ secrets.TWINE_PASSWORD }}
run: |
@@ -181,22 +182,23 @@ jobs:
fail-fast: false
matrix:
python-version:
- - 2.7
- - 3.5
- - pypy-2.7
- - pypy-3.6
- - 3.6
- - 3.7
- - 3.8
- - 3.9
+ - "2.7"
+ - "3.5"
+ - "pypy-2.7"
+ - "pypy-3.7"
+ - "3.6"
+ - "3.7"
+ - "3.8"
+ - "3.9"
+ - "3.10"
os: [ubuntu-20.04, macos-latest]
exclude:
- os: macos-latest
- python-version: pypy-2.7
+ python-version: "pypy-2.7"
- os: macos-latest
- python-version: pypy-3.6
+ python-version: "pypy-3.7"
- os: macos-latest
- python-version: 3.5
+ python-version: "3.5"
steps:
- name: checkout
@@ -272,7 +274,7 @@ jobs:
runs-on: ${{ matrix.os }}
strategy:
matrix:
- python-version: [3.9]
+ python-version: ["3.9"]
os: [ubuntu-20.04]
steps:
@@ -323,7 +325,7 @@ jobs:
runs-on: ${{ matrix.os }}
strategy:
matrix:
- python-version: [3.9]
+ python-version: ["3.9"]
os: [ubuntu-20.04]
steps:
@@ -375,7 +377,7 @@ jobs:
# We use a regular Python matrix entry to share as much code as possible.
strategy:
matrix:
- python-version: [3.9]
+ python-version: ["3.9"]
image: [manylinux2010_x86_64, manylinux2010_i686, manylinux2014_aarch64]
steps:
diff --git a/.manylinux-install.sh b/.manylinux-install.sh
index 6972cae..dda8607 100755
--- a/.manylinux-install.sh
+++ b/.manylinux-install.sh
@@ -28,12 +28,14 @@ yum -y install libffi-devel
# Compile wheels
for PYBIN in /opt/python/*/bin; do
- if [[ "${PYBIN}" == *"cp27"* ]] || \
+ if \
+ [[ "${PYBIN}" == *"cp27"* ]] || \
[[ "${PYBIN}" == *"cp35"* ]] || \
[[ "${PYBIN}" == *"cp36"* ]] || \
[[ "${PYBIN}" == *"cp37"* ]] || \
[[ "${PYBIN}" == *"cp38"* ]] || \
- [[ "${PYBIN}" == *"cp39"* ]]; then
+ [[ "${PYBIN}" == *"cp39"* ]] || \
+ [[ "${PYBIN}" == *"cp310"* ]] ; then
"${PYBIN}/pip" install -e /io/
"${PYBIN}/pip" wheel /io/ -w wheelhouse/
if [ `uname -m` == 'aarch64' ]; then
diff --git a/.meta.toml b/.meta.toml
index 5081d26..0e4378d 100644
--- a/.meta.toml
+++ b/.meta.toml
@@ -2,7 +2,7 @@
# https://github.com/zopefoundation/meta/tree/master/config/c-code
[meta]
template = "c-code"
-commit-id = "5b60e8235223c5c73427d4cdf66be5fb2cce3cea"
+commit-id = "23625f0c67c2171441dbe2069830d3b3fdb17757"
[python]
with-appveyor = true
diff --git a/appveyor.yml b/appveyor.yml
index 9816396..493bf43 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -21,6 +21,8 @@ environment:
- python: 38-x64
- python: 39
- python: 39-x64
+ - python: 310
+ - python: 310-x64
install:
- "SET PYTHONVERSION=%PYTHON%"
diff --git a/tox.ini b/tox.ini
index 526fada..7c625bd 100644
--- a/tox.ini
+++ b/tox.ini
@@ -10,6 +10,7 @@ envlist =
py37,py37-pure
py38,py38-pure
py39,py39-pure
+ py310,py310-pure
pypy
pypy3
docs
@@ -19,7 +20,6 @@ envlist =
[testenv]
usedevelop = true
deps =
- wheel
setenv =
pure: PURE_PYTHON=1
!pure-!pypy-!pypy3: PURE_PYTHON=0
@@ -52,7 +52,7 @@ skip_install = true
deps =
flake8
check-manifest
- check-python-versions
+ check-python-versions >= 0.19.1
wheel
commands =
flake8 src setup.py